List:General Discussion« Previous MessageNext Message »
From:Dermot Date:April 1 2009 3:45pm
Subject:mysqldump failing to load data
View as plain text  
Hi,

MySQL v4.1.22 on Linux 2.6.18-6-686

I have a dump file generate with mysqldump created by a version 4.1.10 server.

I want to import the dump file into a different server. When I run

mysqldump --database mydb --debug < mydumpfile.sql

I get the following:

-- MySQL dump 10.9
--
-- Host: localhost    Database: mydb
-- ------------------------------------------------------
-- Server version	4.1.22-debug-log

/*!40101 SET @OLD_CHARACTER_SET_CLIENT=@@CHARACTER_SET_CLIENT */;
/*!40101 SET @OLD_CHARACTER_SET_RESULTS=@@CHARACTER_SET_RESULTS */;
/*!40101 SET @OLD_COLLATION_CONNECTION=@@COLLATION_CONNECTION */;
/*!40101 SET NAMES utf8 */;
/*!40014 SET @OLD_UNIQUE_CHECKS=@@UNIQUE_CHECKS, UNIQUE_CHECKS=0 */;
/*!40014 SET @OLD_FOREIGN_KEY_CHECKS=@@FOREIGN_KEY_CHECKS,
FOREIGN_KEY_CHECKS=0 */;
/*!40101 SET @OLD_SQL_MODE=@@SQL_MODE, SQL_MODE='NO_AUTO_VALUE_ON_ZERO' */;
/*!40111 SET @OLD_SQL_NOTES=@@SQL_NOTES, SQL_NOTES=0 */;

/*!40101 SET SQL_MODE=@OLD_SQL_MODE */;
/*!40014 SET FOREIGN_KEY_CHECKS=@OLD_FOREIGN_KEY_CHECKS */;
/*!40014 SET UNIQUE_CHECKS=@OLD_UNIQUE_CHECKS */;
/*!40101 SET CHARACTER_SET_CLIENT=@OLD_CHARACTER_SET_CLIENT */;
/*!40101 SET CHARACTER_SET_RESULTS=@OLD_CHARACTER_SET_RESULTS */;
/*!40101 SET COLLATION_CONNECTION=@OLD_COLLATION_CONNECTION */;
/*!40111 SET SQL_NOTES=@OLD_SQL_NOTES */;


The database remains empty. Is there some incompatibility between the
data I am trying to import and the installed server?

There is the following from the trace log:
| <cli_read_query_result
| >mysql_select_db
| | enter: db: 'spl2'
| | >net_clear
| | | >vio_blocking
| | | | enter: set_blocking_mode: 0  old_mode: 1
| | | | exit: 0
| | | <vio_blocking
| | | >vio_read
| | | | enter: sd=4, buf=0xb7c97008, size=1047551
| | | | vio_error: Got error 11 during read
| | | | exit: -1
| | | <vio_read
| | | >vio_blocking
| | | | enter: set_blocking_mode: 1  old_mode: 0
| | | | exit: 0
| | | <vio_blocking
| | <net_clear
....

User time 0.01, System time 0.00
Maximum resident set size 0, Integral resident set size 0
Non-physical pagefaults 679, Physical pagefaults 0, Swaps 0
Blocks in 0 out 0, Messages in 0 out 0, Signals 0
Voluntary context switches 4, Involuntary context switches 3


Does anyone have any ideas what the probem might be?
Thanx,
Dp.
Thread
mysqldump failing to load dataDermot1 Apr
  • Re: mysqldump failing to load dataVirgilio Quilario2 Apr
    • Re: mysqldump failing to load dataewen fortune2 Apr