List:General Discussion« Previous MessageNext Message »
From:Claudio Nanni Date:January 14 2009 2:02pm
Subject:Re: default storage engine
View as plain text  
I don't know if this can be useful,
just a few things I found out.
INNODB engine does not start if you have already files into the directory
and you change the file size in the my.cnf either of the innodb Datafile or
innodb Logfile,
remove innodb files before starting mysql.
Moreover MyISAM is the default storage engine so it should not be specified.

Cheers
Claudio Nanni


2009/1/14 Walter Heck <lists@stripped>

> You can only copy files liek that for MyISAM tables. Are you sure you
> didn't
> accidentally convert to INNODB somewhere along the line? If so, go back to
> your old install and dump everything so you can import it in the new
> install, or convert everything back to MyISAM in the old install before
> moving the files over.
>
> Of course you should chose the appropriate table type for each and every
> table in your database, but when load is very very low and you don't expect
> any growth I guess it is not your first concern.
>
> Kind regards,
>
> Walter
>
> Need MySQL advice?
> OlinData.com is the place to go! (http://www.olindata.com)
>
>
> On Wed, Jan 14, 2009 at 11:36 AM, <mikesz@stripped> wrote:
>
> > Hello mysql,
> >
> > Greetings in the New Year to everyone. Hope for only good things...
> >
> > I have been using a WAMP for maybe 5 years, started with Apache2Triad
> > and eventually evolved to WAMPSERVER which is what I am running now.
> > Over the years, I have upgraded my server many times and the procedure
> > that has always worked was to do a clean install and "drop" my data
> > into the data folder, fire it up and every thing works. I did have a
> > hiccup when I switched from Apache2Triad because WAMPSERVER defaults
> > to INNODB and ALL my work is MYISAM so after I figured out that I just
> > need to change the default storage engine, everything worked as
> > expected, copy the files, fire it up and it works. THIS TIME, I have a
> > real problem because the default storage engine has disappeared from
> > the my.ini file and if I put it in MySQL does not even start anymore.
> >
> > Not only that, when I copy the database files into the data folder,
> > many of them seem to be corrupted now for some unknown reason.
> >
> > When I do a diff on the my.ini file the new one looks nothing at all
> > like the previous version so my question is what happened? If anyone
> > knows.
> >
> > --
> > Best regards,
> >  mikesz                          mailto:mikesz@stripped
> >
> >
> > --
> > MySQL General Mailing List
> > For list archives: http://lists.mysql.com/mysql
> > To unsubscribe:    http://lists.mysql.com/mysql?unsub=1
> >
> >
>

Thread
default storage enginemikesz14 Jan
  • Re: default storage engineWalter Heck14 Jan
    • Re: default storage engineClaudio Nanni14 Jan