List:General Discussion« Previous MessageNext Message »
From:Bai Shen Date:December 1 2008 8:44pm
Subject:Updating from MySQL 4.0.12 to 5.0.67 Community
View as plain text  
I currently have an application that runs on MySQL 4.0.12.  I'd like to
update it to the newest version of MySQL so I can have multiple applications
using the one database.  However, I'm running into some permissions
problems.

When I install MySQL 4.0.12 I set up an administrator user.  Then I run
mysql.exe and I'm able to create a new database for the application.  I
don't log in or anything like that.

Now I've stood up MySQL 5.0.67 on another machine.  I've recreated the same
administrator user, but I'm not sure how to give them the priveleges, since
I didn't do anything like that with the older version.  And when I try to
create the database using mysql.exe I get the following error.

ERROR 1044 (42000): Access denied for user ''@'localhost' to database
'newdb'

So I'm assuming that my permissions aren't setup correctly, but I'm not sure
what I need to change.  5.0.67 seems to handle the administration fairly
differently than 4.0.12.  Also, I'm not running the newer version as a
service.  I don't think that would effect things, but I figured I should
mention it.

TIA.

Bai Shen

Thread
Updating from MySQL 4.0.12 to 5.0.67 CommunityBai Shen1 Dec
  • Re: Updating from MySQL 4.0.12 to 5.0.67 CommunityClaudio Nanni1 Dec
    • Re: Updating from MySQL 4.0.12 to 5.0.67 CommunityChandru2 Dec