List:General Discussion« Previous MessageNext Message »
From:Dan Nelson Date:October 23 2007 7:03pm
Subject:Re: upgrade from 4.1 to 5.0 KO
View as plain text  
In the last episode (Oct 23), Ivan Longhi said:
> I'm running mysql-server on a linux debian box
>
> with apt package system I upgraded mysql server from 4.1 to 5.0 (apt
> automatically execute mysql_upgrade....)
>
> now on my 5.0.32 server almost everything works fine, except for a
> database containing 4 tables: two of them have been upgraded as I can
> see from the extension of the files (.frm, .MYD and .MYI) and I can
> use them without problems, but the other two tables seem not to have
> been upgraded as they are still with 4.1 extensions (.frm, .ISM and
> .ISD).
>
> if I try to operate with them I obtain the mysql error ERROR 1017
> (HY000): Can't find file: 'tablename' (errno: 2) I tried to run
> mysql_upgrade again with --force option but It seems they are not
> considered

You'll need to downgrade to 4.1 and then convert those ISAM tables to
MYISAM, or copy those files to a system that is running 4.1 and do the
conversion there.  ISAM format was deprecated in 4.0 and support was
removed in 5.0.

-- 
	Dan Nelson
	dnelson@stripped
Thread
upgrade from 4.1 to 5.0 KOIvan Longhi23 Oct
  • Re: upgrade from 4.1 to 5.0 KODan Nelson23 Oct