List:General Discussion« Previous MessageNext Message »
From:thomas Armstrong Date:October 4 2007 3:06pm
Subject:Re: How to change "long_query_time" with mySql 3.23
View as plain text  
It looks like mySQL is taking ok the "long_query_time" value by using
--------
set-variable=long_query_time=5
--------

If I display mySQL parameters:
------
long_query_time       current value: 10
------

However, there are tons of lines like this one:
------
# User@Host: root[root] @ localhost []
# Query_time: 0  Lock_time: 0  Rows_sent: 1  Rows_examined: 20
--------

This is not a slow query, is it?


On 10/4/07, Jørn Dahl-Stamnes <sql03@stripped> wrote:
> On Thursday 04 October 2007 14:06, thomas Armstrong wrote:
> > Hi.
> >
> > I'm suffering a severe slowness of my server (mySQL 3.23), and want to
> > detect Slow Queries.
> >
> > I installed mySQL on '/usr/local/mysql', and works ok. But if I insert
> > this line into '/etc/my.cnf':
> > -----
> > log-slow-queries = /usr/local/mysql/log/slow-queries.log
> > long_query_time = 5
> > -----
> > it won't restart. If I comment the second line, it works ok.
>
> Try to remove the spaces in the two lines. If my memory is correct, I had the
> same problem some time ago and it went away when removing the spaces.
>
> --
> Jørn Dahl-Stamnes
> homepage: http://www.dahl-stamnes.net/dahls/
>
Thread
How to change "long_query_time" with mySql 3.23thomas Armstrong4 Oct
  • Re: How to change "long_query_time" with mySql 3.23thomas Armstrong4 Oct
Re: How to change "long_query_time" with mySql 3.23thomas Armstrong4 Oct
  • Re: How to change "long_query_time" with mySql 3.23Baron Schwartz4 Oct