List:General Discussion« Previous MessageNext Message »
From:Tim Johnson Date:August 2 2007 7:12pm
Subject:Re: Update error on ver 3.23, works on ver 5.0
View as plain text  
On Thursday 02 August 2007, Tim Johnson wrote:
> Hi:
> I use 5.0.38 on my ubuntu desktop
> and I have to work with ver 3.23.56 on a solaris-based server.
>
> The following update query:
> UPDATE wine_list,FRED SET wine_list.wine_ID=FRED.WMJ_ID WHERE
> wine_list.wine_ID=FRED.wine_ID;
>
> works on 5.038, but on 3.23.56 I get the following:
> ERROR 1064 (00000): You have an error in your SQL syntax near 'FRED SET
> wine_list.wine_ID=FRED.WMJ_ID WHERE wine_list.wine_ID=FRED.wine_ID' at line
   :-) Now I know why I upgraded from 3~ - it looks like the ability to 
update a table with values from another table was added at version 4.04.

I could dump the table, run the update on my desktop and re-install, *but* 
time is of the essence, 'cuz an update of wine_list on the server while I'm 
operating on it on my desktop could cause some grief...

any other ideas?

thanks
tim
Thread
Update error on ver 3.23, works on ver 5.0Tim Johnson2 Aug
  • Re: Update error on ver 3.23, works on ver 5.0Baron Schwartz2 Aug
  • Re: Update error on ver 3.23, works on ver 5.0Tim Johnson2 Aug