List:General Discussion« Previous MessageNext Message »
From:Tim Johnson Date:August 2 2007 6:59pm
Subject:Update error on ver 3.23, works on ver 5.0
View as plain text  
Hi:
I use 5.0.38 on my ubuntu desktop
and I have to work with ver 3.23.56 on a solaris-based server.

The following update query:
UPDATE wine_list,FRED SET wine_list.wine_ID=FRED.WMJ_ID WHERE 
wine_list.wine_ID=FRED.wine_ID;

works on 5.038, but on 3.23.56 I get the following:
ERROR 1064 (00000): You have an error in your SQL syntax near 'FRED SET 
wine_list.wine_ID=FRED.WMJ_ID WHERE wine_list.wine_ID=FRED.wine_ID' at line 1

Any ideas on how to make it work? Pointers to error codes would be helpful, 
also.

thanks
tim
Thread
Update error on ver 3.23, works on ver 5.0Tim Johnson2 Aug
  • Re: Update error on ver 3.23, works on ver 5.0Baron Schwartz2 Aug
  • Re: Update error on ver 3.23, works on ver 5.0Tim Johnson2 Aug