List:General Discussion« Previous MessageNext Message »
From:Giulio Troccoli Date:July 26 2007 10:49am
Subject:Error compiling on Solaris 6
View as plain text  
Good morning,

I am trying to build MySQL from source on Solaris 6. A pre-compiled
version is not available for Solaris 6 and we cannot upgrade the OS to
Solaris 8.

I currently have Ver 9,38 Ditrib 3.22.32 installed, but the main MySQL
Server (the one one Solaris is used as a client only) has been recently
upgraded to Ver 14.12 Distrib 5.0.27 and we have problems with
privileges, where "Client does not support authentication protocol
requested by server; consider upgrading MySQL client". There you go, I
have to upgrade my client.

I have downloaded the Compressed GNU TAR archive, unzipped and untarred,
read the INSTALL-FILE and as suggested run the command

CFLAGS="-O3" CXX=gcc CXXFLAGS="-O3 -felide-constructors \
-fno-exceptions -fno-rtti" ./configure \
--prefix=/usr/local/mysql --enable-assembler \
--with-mysqld-ldflags=-all-static

And then make it. But this result in the following error

make[4]: Entering directory `/usr/local/src/mysql-5.0.45/sql'
/bin/ksh ../libtool --preserve-dup-deps --tag=CXX --mode=link gcc
-DDBUG_OFF -O3 -felide-constructors             -fno-exceptions
-fno-rtti   -fno-implicit-templates -fno-exceptions -fno-rtti
-DHAVE_RWLOCK_T   -o mysql_tzinfo_to_sql  mysql_tzinfo_to_sql.o
-all-static ../myisam/libmyisam.a ../myisammrg/libmyisammrg.a
../heap/libheap.a ../vio/libvio.a ../mysys/libmysys.a ../dbug/libdbug.a
../regex/libregex.a ../strings/libmystrings.a -lz   -lpthread -lthread
-lposix4 -lresolv -lgen -lsocket -lnsl -lm  -lpthread -lthread 
gcc -DDBUG_OFF -O3 -felide-constructors -fno-exceptions -fno-rtti
-fno-implicit-templates -fno-exceptions -fno-rtti -DHAVE_RWLOCK_T -o
mysql_tzinfo_to_sql mysql_tzinfo_to_sql.o -static  ../myisam/libmyisam.a
../myisammrg/libmyisammrg.a ../heap/libheap.a ../vio/libvio.a
../mysys/libmysys.a ../dbug/libdbug.a ../regex/libregex.a
../strings/libmystrings.a -lz -lpthread -lthread -lposix4 -lresolv -lgen
-lsocket -lnsl -lm -lpthread -lthread
/usr/local/bin/ld: cannot find -lpthread
collect2: ld returned 1 exit status
make[4]: *** [mysql_tzinfo_to_sql] Error 1
make[4]: Leaving directory `/usr/local/src/mysql-5.0.45/sql'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/usr/local/src/mysql-5.0.45/sql'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/usr/local/src/mysql-5.0.45/sql'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/local/src/mysql-5.0.45'
make: *** [all] Error 2

I read than make on Solaris sometimes have problems, but I heard that
GNU 3.75 works fine with MySql and I should be fine

pvwdev-s mysql-5.0.45> make --version
GNU Make version 3.76.1, by Richard Stallman and Roland McGrath.

Can anybody help me please? It's quite important and a bit urgent.

PLEASE reply to me as well as to the list because I am not subscribed.

Many thanks
Giulio
Thread
Error compiling on Solaris 6Giulio Troccoli26 Jul
  • Re: Error compiling on Solaris 6mysql26 Jul
    • RE: Error compiling on Solaris 6Giulio Troccoli26 Jul
      • Migration from Oracle to MySQLSrikalyan Tangirala26 Jul
        • Re: Migration from Oracle to MySQLGrant Allen27 Jul
          • Re: Migration from Oracle to MySQLMark Kirkwood30 Jul
    • Re: Migration from Oracle to MySQLMartijn Tonies26 Jul
    • Re: Migration from Oracle to MySQLMartijn Tonies30 Jul
      • Re: Migration from Oracle to MySQLMark Kirkwood31 Jul
    • Re: Migration from Oracle to MySQLMartijn Tonies31 Jul
RE: Migration from Oracle to MySQLRajesh Mehrotra26 Jul
  • RE: Migration from Oracle to MySQLSrikalyan Tangirala26 Jul
  • RE: Migration from Oracle to MySQLsliebman26 Jul
  • Re: Migration from Oracle to MySQLLuca Ferrari27 Jul