List:General Discussion« Previous MessageNext Message »
From:Daevid Vincent Date:May 14 2007 7:32pm
Subject:FW: Two Denial of Service vulnerabilities in mySQL < 5.0.38
View as plain text  
Sorry if this was already posted, but I don't recall seeing it, and I read the list every
day.

I also checked here: http://lists.mysql.com/mysql and didn't see any mention.

This makes me a little concerned. Why aren't these security issues being posted to the
list? This is at least the third one I've
seen on the Gentoo GLSA list, that hasn't had a mysql list equivallent. 

-----Original Message-----
From: Raphael Marichez [mailto:falco@stripped] 
Sent: Tuesday, May 08, 2007 9:37 AM
To: gentoo-announce@stripped
Cc: bugtraq@stripped; full-disclosure@stripped;
security-alerts@stripped
Subject: [gentoo-announce] [ GLSA 200705-11 ] MySQL: Two Denial of Service vulnerabilities

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200705-11
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: MySQL: Two Denial of Service vulnerabilities
      Date: May 08, 2007
      Bugs: #170126, #171934
        ID: 200705-11

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Two Denial of Service vulnerabilities have been discovered in MySQL.

Background
==========

MySQL is a popular multi-threaded, multi-user SQL server.

Affected packages
=================

    -------------------------------------------------------------------
     Package       /  Vulnerable  /                         Unaffected
    -------------------------------------------------------------------
  1  dev-db/mysql      < 5.0.38                              >= 5.0.38
                                                                 < 5.0

Description
===========

mu-b discovered a NULL pointer dereference in item_cmpfunc.cc when
processing certain types of SQL requests. Sec Consult also discovered
another NULL pointer dereference when sorting certain types of queries
on the database metadata.

Impact
======

In both cases, a remote attacker could send a specially crafted SQL
request to the server, possibly resulting in a server crash. Note that
the attacker needs the ability to execute SELECT queries.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All MySQL users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=dev-db/mysql-5.0.38"

References
==========

  [ 1 ] Original Report
        http://bugs.mysql.com/bug.php?id=27513
  [ 2 ] CVE-2007-1420
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-1420

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200705-11.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@stripped or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2007 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

Thread
FW: Two Denial of Service vulnerabilities in mySQL < 5.0.38Daevid Vincent14 May