List:General Discussion« Previous MessageNext Message »
From:Martijn Tonies Date:March 5 2007 7:27pm
Subject:Re: migrating 4.0 to 5.0
View as plain text  
>> > i've still serious trouble in migrating databases createted with 4.0 to
>> 5.0.
>> > the problems is still the charset. i'm connecting to mysql with php and
>> when
>> > i try to use the 5.0 db german special chars are messed up. afaik 4.0
> > uses latin charset and 5.0 utf8 by default. can some one please give me
a
> > hint
> how
>>
> > to migrate ? i think i'm just too stupid  :-)
>>
>> Why not set your database to latin instead?
>
>tried this with out success - how to do it right ? reagrdless what my.cnf
is
>set to e.g. phpmyadmin reports to me that the db charset is UTF8. when i
look
>at the tables they show up as latin1 but my own php apps do not who german
>special chars as they used to ...

If the characterset for your tables is "latin", then this
should be OK.

But do you also specify the connection/client characterset?

If your server defaults to "utf8", setting it after connecting
might be required.

Martijn Tonies
Database Workbench - tool for InterBase, Firebird, MySQL, NexusDB, Oracle &
MS SQL Server
Upscene Productions
http://www.upscene.com
My thoughts:
http://blog.upscene.com/martijn/
Database development questions? Check the forum!
http://www.databasedevelopmentforum.com

Thread
migrating 4.0 to 5.0Matthias Henze5 Mar
  • Re: migrating 4.0 to 5.0Mario Guenterberg5 Mar
  • Re: migrating 4.0 to 5.0Martijn Tonies5 Mar
    • Re: migrating 4.0 to 5.0Matthias Henze5 Mar
  • Re: migrating 4.0 to 5.0Martijn Tonies5 Mar
RE: migrating 4.0 to 5.0Timothy Little9 Mar