List:General Discussion« Previous MessageNext Message »
From:Eric Anderson Date:October 5 2006 10:45pm
Subject:Replication
View as plain text  
I'm having a problem with my replication settings in my.cnf.  I know 
it's probably something stupid.

I've got an existing database configured to replicate as follows:

set-variable    = binlog-do-db=DatabaseA
set-variable    = replicate-do-table=DatabaseA.foo_t

and that replicates that one single table just fine.

I'm trying to replicate a single table from another database:

set-variable    = binlog-do-db=DatabaseB
set-variable    = replicate-do-table=DatabaseB.bar_t

but nothing gets replicated.  There is a MRG table in DatabaseB though, 
but adding the following:

set-variable    = binlog-do-db=DatabaseB
set-variable    = replicate-do-table=DatabaseB.bar_t
set-variable    = replicate-ignore-table=DatabaseB.merge_t

doesn't help.  The following works though:

set-variable    = binlog-do-db=DatabaseB
set-variable    = replicate-wild-do-table=DatabaseB.%
set-variable    = replicate-ignore-table=DatabaseB.merge_t

but that replicates all tables except for the MRG table and I'd rather 
not replicate all the tables.  Any ideas?

--

WANT TO MODEL FOR MAC & BUMBLE?  APPLY AT http://casting.macandbumble.com
-------------------------------------------------------------------------
  Eric Anderson         Mac and Bumble               Bumble Cash
   ICQ 3849549   http://www.macandbumble.com  http://www.bumblecash.com
  San Diego, CA    <eric@stripped>      <eric@stripped>
-------------------------------------------------------------------------
     SEE OUR LATEST PARTY PICTURES -- http://events.macandbumble.com/
Thread
ReplicationEric Anderson6 Oct
  • Re: ReplicationVisolve DB Team6 Oct
    • Re: ReplicationEric Anderson6 Oct