List:General Discussion« Previous MessageNext Message »
From:Joerg Bruehe Date:April 24 2006 7:40pm
Subject:Re: Older version MySQL
View as plain text  
Mike, all,

the packages you need should exist:

Mike Blezien wrote:
> Hello,
> I am attempting to upgrade one of our older servers running RH 7.3 
> w/glibc-2.2.5-44

Ok, so you need a package for glibc 2.2.
There are two choices, both on the 4.0 download page:

1) From the section "Linux (non RPM package) downloads", first row, a 
"tar.gz":  "Linux (x86, glibc-2.2, ..."

2) A bit further down, the RPMs:
"Linux x86 generic RPM (statically linked against glibc 2.2.5) downloads"
Here, the "server" and "client" RPMs do not require the glibc 2.3.

> it's currently using 3.23.58 and tried installing 4.0.26 rpm's for 
> linux, but won't install due to the following error:
>   is needed by MySQL-shared-4.0.26-0
>   is needed by MySQL-shared-4.0.26-0
>   is needed by MySQL-shared-compat-4.0.26-0
>   is needed by 
> MySQL-shared-compat-4.0.26-0

I am surprised the "shared" packages need glibc 2.3, typically this 
should be indicated by a "-glibc23" part in the package name.
For which purpose do you need "shared" and "shared-compat"?

> Now of the RPM's will install. Is there a 4.0.+ version that will 
> install on this type of server without have to upgrade alot of other 
> stuff ?? Or can we build it from source, and if so, what is the 
> recommend configure options used to build from source ?

Yes, you can build it from source.
IMHO, running the RPM build process (using the "spec" file) on your 
machine should even provide these packages.


Joerg Bruehe, Senior Production Engineer
Older version MySQLMike Blezien22 Apr
  • RE: Older version MySQLNicolas Verhaeghe22 Apr
    • RE: Older version MySQLmysql22 Apr
    • Re: Older version MySQLMike Blezien22 Apr
  • RE: Older version MySQLNicolas Verhaeghe24 Apr
  • RE: Older version MySQLNicolas Verhaeghe24 Apr
  • Re: Older version MySQLJoerg Bruehe24 Apr