List:General Discussion« Previous MessageNext Message »
From:Gleb Paharenko Date:October 13 2005 7:59pm
Subject:Re: Problem with GRANT not working.
View as plain text  
Hello.

Enable a General log and find out what is MySQL thinking about the host
from you're connecting to it.

Ben Clewett wrote:
> Dear MySQL,
> 
> A new installation of 4.1.9 on AIX 5. I have a GRANT that is not working.
> 
> Connecting from foreign server 'pho.com' with IP of '192.168.1.1', I
> should be able to GRANT using either:
> 
> mysql> GRANT all ON test.* TO test@'192.168.%' IDENTIFIED BY 'test';
> mysql> GRANT all ON test.* TO test@'%.com'     IDENTIFIED BY 'test';
> 
> The second version '%.com' allows access.  The first version access by
> IP '192.168.%' does not work.
> 
> This always has worked on 4.1.9 before.  There is nothing in the manual
> to elaborate on this problem.  As far as I can see, this should work
> perfectly.
> 
> Would any users be able to suggest a solution to this?
> 
> Regards,
> 
> Ben Clewett.
> 
> 
> 
> 


-- 
For technical support contracts, goto https://order.mysql.com/?ref=ensita
This email is sponsored by Ensita.NET http://www.ensita.net/
   __  ___     ___ ____  __
  /  |/  /_ __/ __/ __ \/ /    Gleb Paharenko
 / /|_/ / // /\ \/ /_/ / /__   Gleb.Paharenko@stripped
/_/  /_/\_, /___/\___\_\___/   MySQL AB / Ensita.NET
       <___/   www.mysql.com



Thread
Problem with GRANT not working.Ben Clewett13 Oct
  • Re: Problem with GRANT not working.Ben Clewett13 Oct
    • Re: Problem with GRANT not working.Gleb Paharenko15 Oct
  • Re: Problem with GRANT not working.Gleb Paharenko15 Oct