List:General Discussion« Previous MessageNext Message »
From:leegold Date:November 3 2004 2:14am
Subject:ampersands in the database fields
View as plain text  
The subject title is a sedgeway into my question that may slightly of
topic but I've asked many sources and don't have an answer yet so I ask
it here.

I have a text fields of html marked up content which I render via php.
Looking at the rendered html page in a text editor I see that ampersands
all appear as   &   When I select the field via sql I also see &

I have a pretty standard seach, Fulltext and substring (ie. %keyword%)
searches. There's an acronym in my content:   NA&SD    and when I try
searching for this it really mucks up. The Fulltext no matter what I try
does not get a hit. The substring search will work properly if I put the
following in the search form:    NA&SD    that works.  But trying
the substring search with   NA&SD   produces weird results...kinda works
but strangely and affects the rendering of the search results page.

So what's the cause of all this? Should I upfront load my db text fields
differently, or, search them differently - what is the  fix  via mysql
or php for the ampersand problem?

Thanks,
Lee G.
Washington DC    
Thread
mysql admin clientsleegold1 Nov
  • Re: mysql admin clientsGleb Paharenko2 Nov
  • Re: mysql admin clientsMartijn Tonies2 Nov
  • Re: mysql admin clientsAndy Davidson2 Nov
    • ampersands in the database fieldsleegold3 Nov
      • Re: ampersands in the database fields-{ Rene Brehmer }-3 Nov
  • Re: mysql admin clientsKaram Chand6 Nov
Re: ampersands in the database fieldsleegold3 Nov