List:General Discussion« Previous MessageNext Message »
From:Rhino Date:October 29 2004 4:43pm
Subject:Re: Extract MySQL Version
View as plain text  
----- Original Message ----- 
From: "Fredrick Bartlett" <palmtreefrb@stripped>
To: <mysql@stripped>
Sent: Friday, October 29, 2004 12:08 PM
Subject: Extract MySQL Version


> I use the following to extract the version number. But it throws an error
on
> newer version 5.xx.  It works on version 4.0 and below.
>
> SELECT SUBSTRING(VERSION(),1,LOCATE("-",VERSION())-1) AS VERSION
>
> On version 5.0.1-alpha-nt-log I get an error...
> Illegal mix of collations
> (utf8_general_ci,IMPLICIT)and(latin1_SWEEDIH_CI,coercible) for operation
> 'locate'
>
> Is this problem by design?
>
Try spelling SWEEDISH correctly and see if that helps.

You left out the second 'S' in 'SWEEDISH_CI' ;-)

Rhino

Thread
mysql 3.23 store large dataJerry Swanson27 Oct
  • Re: mysql 3.23 store large dataGleb Paharenko27 Oct
    • Re: mysql 3.23 store large dataJerry Swanson29 Oct
      • Re: mysql 3.23 store large dataFriedhelm Betz29 Oct
  • Extract MySQL VersionFredrick Bartlett29 Oct
  • Re: Extract MySQL VersionRhino29 Oct
  • Re: Extract MySQL VersionMartijn Tonies29 Oct