List:General Discussion« Previous MessageNext Message »
From:Unreal HSHH Date:September 1 2004 8:23am
Subject:Re: 4.1.4-gamma cannot compile
View as plain text  
Run
aclocal; autoheader; autoconf; automake
I got many warning and one error:

aclocal general some warning:
configure.in:277: warning: underquoted definition of AC_SYS_COMPILER_FLAG
  run info '(automake)Extending aclocal'
  or see http://sources.redhat.com/automake/automake.html#Extending%20aclocal
configure.in:300: warning: underquoted definition of AC_SYS_CPU_COMPILER_FLAG
configure.in:308: warning: underquoted definition of AC_SYS_OS_COMPILER_FLAG
acinclude.m4:4: warning: underquoted definition of
MYSQL_CHECK_READLINE_DECLARES_HIST_ENTRY
acinclude.m4:24: warning: underquoted definition of
MYSQL_CHECK_LIBEDIT_INTERFACE
acinclude.m4:45: warning: underquoted definition of MYSQL_CHECK_NEW_RL_INTERFACE
acinclude.m4:68: warning: underquoted definition of MYSQL_CHECK_SIZEOF
acinclude.m4:97: warning: underquoted definition of MYSQL_TYPE_ACCEPT
acinclude.m4:138: warning: underquoted definition of MYSQL_TYPE_QSORT
acinclude.m4:156: warning: underquoted definition of MYSQL_TIMESPEC_TS
acinclude.m4:175: warning: underquoted definition of MYSQL_TZNAME
acinclude.m4:302: warning: underquoted definition of MYSQL_CHECK_ULONG
acinclude.m4:320: warning: underquoted definition of MYSQL_CHECK_UCHAR
acinclude.m4:338: warning: underquoted definition of MYSQL_CHECK_UINT
acinclude.m4:357: warning: underquoted definition of MYSQL_CHECK_IN_ADDR_T
acinclude.m4:379: warning: underquoted definition of MYSQL_PTHREAD_YIELD
acinclude.m4:418: warning: underquoted definition of MYSQL_CHECK_FP_EXCEPT
acinclude.m4:459: warning: underquoted definition of AM_PROG_CC_STDC
acinclude.m4:503: warning: underquoted definition of AM_SANITY_CHECK
acinclude.m4:522: warning: underquoted definition of MYSQL_CHECK_LIB_TERMCAP
acinclude.m4:543: warning: underquoted definition of MYSQL_SIGNAL_CHECK
acinclude.m4:583: warning: underquoted definition of MYSQL_CHECK_GETPW_FUNCS
acinclude.m4:596: warning: underquoted definition of MYSQL_HAVE_TIOCGWINSZ
acinclude.m4:609: warning: underquoted definition of MYSQL_HAVE_FIONREAD
acinclude.m4:621: warning: underquoted definition of MYSQL_HAVE_TIOCSTAT
acinclude.m4:634: warning: underquoted definition of MYSQL_STRUCT_DIRENT_D_INO
acinclude.m4:668: warning: underquoted definition of MYSQL_TYPE_SIGHANDLER
acinclude.m4:687: warning: underquoted definition of MYSQL_CXX_BOOL
acinclude.m4:706: warning: underquoted definition of MYSQL_STACK_DIRECTION
acinclude.m4:729: warning: underquoted definition of MYSQL_FUNC_ALLOCA
acinclude.m4:798: warning: underquoted definition of
MYSQL_CHECK_LONGLONG_TO_FLOAT
acinclude.m4:823: warning: underquoted definition of MYSQL_CHECK_CPU
acinclude.m4:870: warning: underquoted definition of MYSQL_CHECK_VIO
acinclude.m4:889: warning: underquoted definition of MYSQL_FIND_OPENSSL
acinclude.m4:944: warning: underquoted definition of MYSQL_CHECK_OPENSSL
acinclude.m4:1008: warning: underquoted definition of MYSQL_CHECK_MYSQLFS
acinclude.m4:1036: warning: underquoted definition of MYSQL_CHECK_ORBIT
acinclude.m4:1641: warning: underquoted definition of AC_SYS_LARGEFILE_FLAGS
acinclude.m4:1680: warning: underquoted definition of
AC_SYS_LARGEFILE_SPACE_APPEND
acinclude.m4:1692: warning: underquoted definition of
AC_SYS_LARGEFILE_MACRO_VALUE
acinclude.m4:1711: warning: underquoted definition of MYSQL_SYS_LARGEFILE

autoconf general an error

configure.in:218: error: possibly undefined macro: AC_PROG_LIBTOOL
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.

shell> (cd innobase; aclocal; autoheader; autoconf; automake)
shell> (cd bdb/dist; sh s_all)

reconfigure in mysql src directory,then make,still fail

On Wed, 1 Sep 2004 16:14:51 +0800, Unreal HSHH <hunreal@stripped> wrote:
> got thie error and broken when making mysql 4.1.4-gamma
> 
> automake-1.7: not found
> WARNING: `automake-1.7' is needed, and you do not seem to have it handy on your
>         system.  You might have modified some files without having the
>         proper tools for further handling them.  Check the `README' file,
>         it often tells you about the needed prerequirements for installing
>         this package.  You may also peek at any GNU archive site, in case
>         some other package would contain this missing `automake-1.7' program.
> 
> But I already have automake-1.9
> 
> autoconf-2.59_2
> automake-1.9
> bison-1.875_3
> gmake-3.80_2
> libtool-1.5.6_1
> m4-1.4.1
>
Thread
4.1.4-gamma cannot compileUnreal HSHH1 Sep
  • Re: 4.1.4-gamma cannot compileUnreal HSHH1 Sep
    • Re: 4.1.4-gamma cannot compileUnreal HSHH1 Sep
  • Re: 4.1.4-gamma cannot compilePaul DuBois1 Sep
    • Re: 4.1.4-gamma cannot compileMichael Stassen4 Sep
      • Re: 4.1.4-gamma cannot compilePaul DuBois4 Sep
        • Re: 4.1.4-gamma cannot compileLenz Grimmer6 Sep