List:General Discussion« Previous MessageNext Message »
From:Liying Huang Date:February 12 2004 3:52pm
Subject:Re; Re: question for replication
View as plain text  
Show slave status:


*************************** 1. row ***************************
          Master_Host: lhuang
          Master_User: test
          Master_Port: 3306
        Connect_retry: 60
      Master_Log_File: lhuang-bin.001
  Read_Master_Log_Pos: 79
       Relay_Log_File: liyingtop-relay-bin.001
        Relay_Log_Pos: 120
Relay_Master_Log_File: lhuang-bin.001
     Slave_IO_Running: Yes
    Slave_SQL_Running: Yes
      Replicate_do_db: WITCD,WITTD
  Replicate_ignore_db: mysql
           Last_errno: 0
           Last_error:
         Skip_counter: 0
  Exec_master_log_pos: 79
      Relay_log_space: 116
1 row in set (0.00 sec)

----- Original Message ----- 
From: <vpendleton@stripped>
To: "Liying Huang" <lhuang@stripped>
Cc: <mysql@stripped>Sent: Thursday, February 12, 2004 10:28 AM
Subject: Re: question for replication


What is the output from show slave status?

>>>>>>>>>>>>>>>>>> Original Message
> <<<<<<<<<<<<<<<<<<

On 2/12/04, 8:43:44 AM, Liying Huang <lhuang@stripped> wrote
regarding question for replication:


> Hi,

> I tried to do replication from master-> slave, I used windows,
> MySql 4.0.17 version on both. I have set bin-log option
> in my.cfg in master computer, set master-host, master-user,
master-password,
> replicate-do-db and replicate-ignore-db=mysql, skip-slave-start in
> my.cfg in slave. I have zipped the database from master, copy the zip to
> slave and unzip it, then I start both server, start slave. When I do some
> update in master computer in database, the query showed in master-bin.001
> and it is shown in slave-relay-bin.001 too (slave IO thread seems
working),
> but database in slave doesn't update. What have I done wrong? The
database
> is
> not small, it will take forever if I use 'load data from master', so I
> copy the database instead. The outcome from "Show processlist\G"
> is attached below too. It seems slave SQL thread is running without
problem.

> Liying

> > *************************** 1. row ***************************
> >      Id: 1
> >    User: test
> >    Host: localhost:1110
> >      db: NULL
> > Command: Query
> >    Time: 0
> >   State: NULL
> >    Info: show processlist
> > *************************** 2. row ***************************
> >      Id: 2
> >    User: system user
> >    Host:
> >      db: NULL
> > Command: Connect
> >    Time: 7
> >   State: Waiting for master to send event
> >    Info: NULL
> > *************************** 3. row ***************************
> >      Id: 3
> >    User: system user
> >    Host:
> >      db: NULL
> > Command: Connect
> >    Time: 7
> >   State: Has read all relay log; waiting for the I/O slave thread to
> update
> > it
> >    Info: NULL
> > 3 rows in set (0.02 sec)
> >
> > After I do some update in master, show processlist\G gives me:
> >
> > *************************** 1. row ***************************
> >      Id: 1
> >    User: test
> >    Host: localhost:1110
> >      db: NULL
> > Command: Query
> >    Time: 0
> >   State: NULL
> >    Info: show processlist
> > *************************** 2. row ***************************
> >      Id: 2
> >    User: system user
> >    Host:
> >      db: NULL
> > Command: Connect
> >    Time: 323
> >   State: Waiting for master to send event
> >    Info: NULL
> > *************************** 3. row ***************************
> >      Id: 3
> >    User: system user
> >    Host:
> >      db: NULL
> > Command: Connect
> >    Time: 7
> >   State: Has read all relay log; waiting for the I/O slave thread to
> update
> > it
> >    Info: NULL
> >
> > The time for id 2 and 3 are very differnet.
> >



> --
> MySQL General Mailing List
> For list archives: http://lists.mysql.com/mysql
> To unsubscribe:
http://lists.mysql.com/mysql?unsub=1

-- 
MySQL General Mailing List
For list archives: http://lists.mysql.com/mysql
To unsubscribe:    http://lists.mysql.com/mysql?unsub=1


Thread
RE: [Mysql-discussions] HOW TO RUN SQL and default value ?Remko Lodder9 Feb
  • question about replicationLiying Huang9 Feb
    • Re: question about replicationVictoria Reznichenko10 Feb
  • HOW TO RUN SQLSeena Blace9 Feb
    • Re: HOW TO RUN SQLKKoTY9 Feb
  • Re: question about replicationLiying Huang10 Feb
  • Re: question about replicationLiying Huang10 Feb
    • Re: question about replicationVictoria Reznichenko11 Feb
  • Re: question about replicationLiying Huang11 Feb
  • Re: question about replicationLiying Huang11 Feb
  • question for replicationLiying Huang12 Feb
    • Re: question for replicationvpendleton12 Feb
    • Re: question for replicationVictoria Reznichenko12 Feb
  • Re; Re: question for replicationLiying Huang12 Feb
    • Re: Re; Re: question for replicationvpendleton12 Feb
  • Re: question for replicationLiying Huang12 Feb
  • Re: Re; Re: question for replicationLiying Huang12 Feb
  • Re: Re; Re: question for replicationLiying Huang12 Feb
  • Re: question for replicationLiying Huang12 Feb
  • Re: Re; Re: question for replicationLiying Huang12 Feb
RE: HOW TO RUN SQLRemko Lodder9 Feb