List:General Discussion« Previous MessageNext Message »
From:Pierre-Luc Soucy Date:August 6 2003 5:31pm
Subject:Problem with merge tables in 4.1
View as plain text  
Hi,

I was working on some merge tables this morning and it worked fine, but 
after a few unsuccessful table creation requests (I was making some 
tests), I could not alter or select from a table for the following reason:

mysql> create table test_table (country CHAR(2) NOT NULL) TYPE=MERGE 
UNION=(countries);
Query OK, 0 rows affected (0.00 sec)

mysql> select * from test_table;
ERROR 1016: Can't open file: 'test_table.MRG'. (errno: 143)

mysql> check table test_table;
+-------------------------+-------+----------+-------------------------------------------------+
| Table                   | Op    | Msg_type | 
Msg_text                                        |
+-------------------------+-------+----------+-------------------------------------------------+
| statscounter.test_table | check | error    | Can't open file: 
'test_table.MRG'. (errno: 143) |
+-------------------------+-------+----------+-------------------------------------------------+
1 row in set (0.00 sec)

mysql> repair table test_table;
+-------------------------+--------+----------+-------------------------------------------------+
| Table                   | Op     | Msg_type | 
Msg_text                                        |
+-------------------------+--------+----------+-------------------------------------------------+
| statscounter.test_table | repair | error    | Can't open file: 
'test_table.MRG'. (errno: 143) |
+-------------------------+--------+----------+-------------------------------------------------+
1 row in set (0.00 sec)

I then dropped the table and attempted to create a new one, with no 
success. Also tried another table name, or putting the table in another 
database, and that did not work either. Since it worked earlier, I tried 
restarting the MySQL server, but that didn't correct the problem either.

Do you have any idea of what I'm doing wrong, or what needs to be done 
to get rid of that error?

I thought about submitting a bug report but do not know how this error 
could be reproduced on another machine.

I am running 4.1.0 on dual-CPU debian box with SCSI RAID hard drives, if 
that can help.

Thanks!

Pierre-Luc Soucy

Thread
Problem with merge tables in 4.1Pierre-Luc Soucy6 Aug
  • Re: Problem with merge tables in 4.1Dan Nelson6 Aug
    • Re: Problem with merge tables in 4.1Pierre-Luc Soucy7 Aug