List:General Discussion« Previous MessageNext Message »
From:stu zimny Date:May 28 2003 9:13pm
Subject:mysqlhotcopy script problem
View as plain text  
Greetings:

Attempting to run mysqlhotcopy on my RH 7.3 server/ MySQL 4.012 generates 
the following:


install_driver(mysql) failed: Can't load 
'/usr/lib/perl5/site_perl/5.6.1/i386-linux/auto/DBD/mysql/mysql.so' for 
module DBD::mysql: libmysqlclient.so.10: cannot open shared object file: No 
such file or directory at /usr/lib/perl5/5.6.1/i386-linux/DynaLoader.pm 
line 206.
at (eval 1) line 3
Compilation failed in require at (eval 1) line 3.
Perhaps a required shared library or dll isn't installed where expected

However, mysql.so is present in the proper path so I suspect the error 
message might be a "red-herring".

As well,  the requisite RPMs are present, ie:

perl-DBI
perl-DBD-MySQL

Has anyone experienced this error and gotten past it?

Much thanks,

-stu


Thread
upgrading to v 4.1Ted Rogers28 May
  • Re: upgrading to v 4.1Scott Haneda28 May
    • mysqlhotcopy script problemstu zimny28 May
    • RE: upgrading to v 4.1Daevid Vincent29 May
  • RE: upgrading to v 4.1Kieran Kelleher29 May
  • Re: upgrading to v 4.1LS29 May
    • Re: upgrading to v 4.1Jocelyn Fournier29 May
      • Re: upgrading to v 4.1LS29 May
    • timestamps and time zones2Hosts.com29 May
      • Re: timestamps and time zonesEgor Egorov29 May
        • RE: timestamps and time zonesAndrew Hazen29 May
    • Re: upgrading to v 4.1Jeremy Zawodny29 May
      • Re: upgrading to v 4.1LS30 May