The flag names in 5.1 are misleading as is. The HA_ONLINE_XXX flags
behave the same as HA_ONLINE_XXX_NO_WRITES, and neither are really
"online". This has caused confusion for me in the past, and will
likely cause confusion for others in the future. That is why I would
not mind seeing the variable names change in both 5.1 and 5.5, with
perhaps a comment somewhere in 5.1 that states HA_XXX_NO_WRITE behaves
I think keeping the old flags for backwards compatibility just makes
things more confusing for future storage engine developers.
Just my $.02.
On Tue, Jan 18, 2011 at 9:55 AM, Jon Olav Hauglid
> On 01/17/2011 04:48 PM, Zardosht Kasheff wrote:
>> If the only change is in variable names (and therefore very safe), I
>> think it would be nice if the changes for these changes to be in 5.1
>> as well. Otherwise, storage engine developers will need to use one set
>> of flags when compiling their handlerton against 5.1, and another
>> while compiling against 5.5.
>> Is there any reason to not have this in 5.1?
> The patch is not variable name renames only. Renaming the flags in 5.1
> would not be very meaningful without bug fix as the new names are misleading
> without it.
> We have discussed making the whole patch for 5.1, but this was thought
> to be a bit too risky.
> What we can do, is to add backward compatible defines to 5.5 like I
> suggested in my initial e-mail.
> --- Jon Olav Hauglid