List:Internals« Previous MessageNext Message »
From:Zardosht Kasheff Date:May 22 2010 3:27pm
Subject:Re: running replication tests with storage engine plugin installed
View as plain text  
excellent. Thanks a lot!

-Zardosht

On Sat, May 22, 2010 at 11:24 AM, Sergei Golubchik <serg@stripped> wrote:
> Hi, Zardosht!
>
> On May 22, Zardosht Kasheff wrote:
>>
>> It would be great to run tests with both the innodb plugin and our
>> plugin installed. The real problem comes when we have additional
>> variables passed in via --mysqld that are defined in our engine. When
>> the innodb_plugin test tries to run, because our engine is not loaded,
>> the variable passed in is undefined and the test fails to run.
>>
>> Any ideas?
>
> This is easy. We have --loose prefix precisely for this purpose, start
> all your options with it. E.g. instead of --tokudb-number=15 write
> --loose-tokudb-number=15.
>
> --loose turns "unknown option" error into a warning.
>
> Regards,
> Sergei
>
Thread
running replication tests with storage engine plugin installedZardosht Kasheff4 May
  • Re: running replication tests with storage engine plugin installedMARK CALLAGHAN5 May
    • Re: running replication tests with storage engine plugin installedZardosht Kasheff5 May
      • Re: running replication tests with storage engine plugin installedZardosht Kasheff22 May
        • Re: running replication tests with storage engine plugin installedSergei Golubchik22 May
          • Re: running replication tests with storage engine plugin installedZardosht Kasheff22 May
Re: running replication tests with storage engine plugin installedZardosht Kasheff5 May