List:Internals« Previous MessageNext Message »
From:Michael Widenius Date:May 16 2002 2:15pm
Subject:help / MySQL 3.23.49 vs. BerkeleyDB 4.0.14?
View as plain text  
Hi!

>>>>> "R" == R Blake <R> writes:

R> hi all,
R> i've built mysql-3.23.49 on MacOSX Server 10.1.4, as well as Sleepycat's
R> BerkeleyDB 4.0.14.

R> i note the "--with-berkeley-db" options in configure, but am stumped as to
R> if/how to allow support for the bdb 4.0.14 version.  mysql (in configure,
R> acinclude.m4 & aclocal.m4) seems to limit to bdb-3.x.x support.

R> also, i've read that a "patched bdb" is required in the manual, and that
R> use of a NON-patched bdb will not work .....

R> fyi, InnoDB support seems to work fine as an alternative ......

R> comments on status/implementation?

Currently you have to use the BDB source that is part of the MySQL
distribution if you want to use BDB tables.

We plan to in the near future change to BDB 4.0.14, but just now we
don't have any developer free to do this.

(The patches we have applied are very small and should not be hard to
move to BDB 4.0)

Regards,
Monty
Thread
help / MySQL 3.23.49 vs. BerkeleyDB 4.0.14?R Blake29 Apr
  • help / MySQL 3.23.49 vs. BerkeleyDB 4.0.14?Michael Widenius16 May