List:GUI Tools« Previous MessageNext Message »
From:Jorge del Conde Date:October 22 2002 10:46am
Subject:Re: Cannot build mycc 0.8.5 or use binary (linux)
View as plain text  
Hi!

> Hi there,
>
> i hope anyone can help me.
>
> I've tried to compile the mycc-0.8.5 SRC under Linux (Mandrake 9.0).
>
> [root@dirk mycc-0.8.5-src]# ./configure
> configure: error: cannot find sources in . or ..

A bug managed to make its way through the configure script in 0.8.5 :(

Attached to this email, you'll find a patch (donated by  Fritz Ganter) that
fixes this problem.

> Then i tried the binay (i use the 0.8.4 binary at this time, runs good!)
>
> [root@dirk mycc-0.8.5-linux]# ./mycc
> ./mycc: /lib/i686/libc.so.6: version `GLIBC_2.3' not found (required by
> ./mycc)

That's because your version of glibc is different than the one mycc was
compiled with :(  .. to fix this, you must upgrade to the latest version of
libc.

In the future (probably starting with 0.8.6 which will be released by the
end of this month) there will be different binary packages specific to each
glibc distribution (2.1, 2.2 & 2.3)


Regards,
Jorge
--
For technical support contracts, visit https://order.mysql.com/?ref=mjdc
   __  ___     ___ ____  __
  /  |/  /_ __/ __/ __ \/ /    Mr. Jorge del Conde <jorge@stripped>
 / /|_/ / // /\ \/ /_/ / /__   MySQL AB, Full-Time Developer
/_/  /_/\_, /___/\___\_\___/   Mexico City, Mexico
       <___/   www.mysql.com


----- Original Message -----
From: "Dirk Schlueter" <schlueri@stripped>
To: <mycc@stripped>
Sent: Tuesday, October 22, 2002 1:16 AM
Subject: Cannot build mycc 0.8.5 or use binary (linux)


> Hi there,
>
> i hope anyone can help me.
>
> I've tried to compile the mycc-0.8.5 SRC under Linux (Mandrake 9.0).
>
> [root@dirk mycc-0.8.5-src]# ./configure
> configure: error: cannot find sources in . or ..
>
> Then i tried the binay (i use the 0.8.4 binary at this time, runs good!)
>
> [root@dirk mycc-0.8.5-linux]# ./mycc
> ./mycc: /lib/i686/libc.so.6: version `GLIBC_2.3' not found (required by
> ./mycc)
>
>
> /proc/version ->
> Linux version 2.4.19-16mdk (quintela@stripped) (gcc version
> 3.2 (Mandrake Linux 9.0 3.2-1mdk)) #1 Fri Sep 20 18:15:05 CEST 2002
>
> Glibc 2.2.5
>
> Any ideas for me. Thank you very much!
>
> Greetz
> Dirk
>
>
>
> ---------------------------------------------------------------------
> Before posting please check: http://www.mysql.com/products/mycc/index.html
> posting. To request this thread, email mycc-thread310@stripped
>
> To unsubscribe, send a message to the address shown in the
> List-Unsubscribe header of this message. If you cannot see it,
> email mycc-unsubscribe@stripped instead.
>

Attachment: [application/octet-stream] ganterpatch.diff
Attachment: [application/octet-stream] ganterpatch.diff
Thread
Cannot build mycc 0.8.5 or use binary (linux)Dirk Schlueter22 Oct
  • Re: Cannot build mycc 0.8.5 or use binary (linux)Jorge del Conde22 Oct