List:Eventum General Discussion« Previous MessageNext Message »
From:Joao Prado Maia Date:June 1 2004 3:08pm
Subject:RE: What are the required details for the php.ini file to install eventum onto the latest builds for PHP 4.X, MySQL, Apache 1.3.X?
View as plain text  
Todd,

> Howdy folks,
> i was just trying to install a clean instance of eventum and I am not able
> to do so. I am getting a message "Invalid default value for
> 'sta_id' " when
> I try the installation.
>

This error is probably related to the current state of the bitkeeper
snapshot tarball. We are currently in the process of migrating some changes
to the repository and creating a real 1.0 release, so the code is not stable
yet. I would recommend to stay with the old tarball that you were using
before.


> I have experienced this problem before and it was resolved by tweaking the
> php.ini file and playing around with the hostnames (server, apache). I
> don't have this file anymore and I can't remember the exact
> details of what
> was required to obtain a successful installation.
>

The requirements for Eventum are the following:

----------------
System Requirements
- PHP 4.1.0 or newer versions
- PCRE Extension (usually enabled by default with newer PHP versions)
- MySQL Extension (built-in support with most PHP distributions)
- MySQL Database Server

Graphical Statistics - In order to make the graphical statistics work
properly, you will need PHP's GD extension.
Email Integration - The email integration module requires PHP's IMAP
extension and also a POP3/IMAP server that allows connections to their
appropriate ports.
-----------------


> Can anyone provide the details of a php.ini file that has been used to
> install eventum successfully - preferably a newer php build with apache.
>

If your php.ini file is missing any important directives, Eventum's
installation page will warn you about it.

--Joao

Thread
What are the required details for the php.ini file to install eventumonto the latest builds for PHP 4.X, MySQL, Apache 1.3.X?todd.morgan1 Jun
  • RE: What are the required details for the php.ini file to install eventum onto the latest builds for PHP 4.X, MySQL, Apache 1.3.X?Joao Prado Maia1 Jun