List:Eventum General Discussion« Previous MessageNext Message »
From:Bryan Alsdorf Date:February 24 2011 5:53pm
Subject:Re: 2.3 to 2.3.1 issue
View as plain text  
Hi,

On 02/23/2011 03:17 PM, Guidroz, Bryan wrote:
> After upgrading from 2.3 to 2.3.1, list.php is blank.
>
> I'm able to log in, select a project, but list.php is blank.
>
> Enabled error reporting in config.php and see the following error on
> list.php
>
> "Fatal error: Call to undefined function filter_var() in
> /var/www/html/lib/eventum/class.misc.php on line 416"
>
> Everything works fine when I go back to 2.3.

In fixing the XSS problem we relied on the filter_* functions. This is 
included by default in PHP 5.2 and later but older versions apparently 
have to install it separately. I will add a check for this in the 
installer and mention it in the requirements. Sorry for the hassle.

If you are on a PHP versions before 5.2 see 
http://pecl.php.net/package/filter

Best Regards,
-- 
Bryan Alsdorf, Lead Web Developer
Monty Program AB. http://montyprogram.com
Thread
2.3 to 2.3.1 issueBryan Guidroz23 Feb
  • Re: 2.3 to 2.3.1 issueBryan Alsdorf24 Feb
    • RE: 2.3 to 2.3.1 issueFaisal Siddiqui24 Feb
      • RE: 2.3 to 2.3.1 issueFaisal Siddiqui24 Feb
        • Re: 2.3 to 2.3.1 issue [new thread]Bryan Alsdorf25 Feb
          • RE: 2.3 to 2.3.1 issue [new thread]Faisal Siddiqui26 Feb
    • RE: 2.3 to 2.3.1 issueBryan Guidroz24 Feb