List:Cluster« Previous MessageNext Message »
From:artfire-kyle Date:November 18 2010 8:43pm
Subject:MySQL CLuster Data Nodes Lose Connection
View as plain text  
I have a cluster up and running, but I am experiencing some strange
behaviour. 

Cluster is fully up and running. Show in management mode confirms all
management, data and API nodes are connected.

When i first bring the cluster up I can properly access the API nodes via
mysql console remotely. After a what seems random amount of time, the data
nodes are not accessable from remote servers.

Restarting mysqld seems to temp. fix it, but then the same thing. The same
API node is available via SSH without losing connection. 

When the remote connection is lost, the management console still shows them
all connected, and I can access API node "A" via the mysql console remotely
VIA API node b and vise versa, but cannot connect from any other server not
tied to the cluster. 

Two things that seem to fix this is, 1) restart the mysqldaemon, but then it
repeats after n time, 2) tcpdump (possibly any net traffic) seems to "wake"
it up again but not always.

I am really stumped here and I appreciate any help you may offer.


-- 
View this message in context:
http://mysql-cluster.1050023.n4.nabble.com/MySQL-CLuster-Data-Nodes-Lose-Connection-tp3049544p3049544.html
Sent from the MySQL - Cluster mailing list archive at Nabble.com.
Thread
MySQL CLuster Data Nodes Lose Connectionartfire-kyle18 Nov
  • RE: MySQL CLuster Data Nodes Lose ConnectionAndrew Morgan19 Nov
    • RE: MySQL CLuster Data Nodes Lose Connectionartfire-kyle19 Nov
      • RE: MySQL CLuster Data Nodes Lose ConnectionAndrew Morgan19 Nov
      • RE: MySQL CLuster Data Nodes Lose ConnectionJeff Sturm19 Nov
        • RE: MySQL CLuster Data Nodes Lose Connectionartfire-kyle22 Nov
          • RE: MySQL CLuster Data Nodes Lose ConnectionJeff Sturm22 Nov
            • RE: MySQL CLuster Data Nodes Lose ConnectionBradley Watkins22 Nov
          • RE: MySQL CLuster Data Nodes Lose ConnectionMatthew Boehm22 Nov