List:Bugs« Previous MessageNext Message »
From:Thimble Smith Date:April 30 2000 8:00pm
Subject:Re: AUTO_INCREMENT bug after inserting negative value
View as plain text  
On Mon, May 01, 2000 at 01:22:35AM +1000, jason king wrote:
> hmm .. now I'm confused .. negative auto_increment values work in my
> Windows version
> 
>   mysql  Ver 9.38 Distrib 3.22.32, for Win95/Win98 (i586)

Yes, it works in 3.22, but not in 3.23, because the way that
auto_increment is handled is totally new in 3.23.

That's the "change" that Monty mentioned in his postscript.

Tim
-- 
Tim Smith   < tim@stripped >  :MySQL Development Team:  Boone, NC  USA.
Thread
AUTO_INCREMENT bug after inserting negative valueManuel Lemos30 Apr
  • Re: AUTO_INCREMENT bug after inserting negative valuesinisa30 Apr
  • AUTO_INCREMENT bug after inserting negative valueMichael Widenius30 Apr
    • RE: AUTO_INCREMENT bug after inserting negative valuejason king30 Apr
      • Re: AUTO_INCREMENT bug after inserting negative valueThimble Smith1 May
      • RE: AUTO_INCREMENT bug after inserting negative valueMichael Widenius1 May
    • Re: AUTO_INCREMENT bug after inserting negative valueManuel Lemos30 Apr
      • Re: AUTO_INCREMENT bug after inserting negative valueMichael Widenius1 May
        • Re: AUTO_INCREMENT bug after inserting negative valueManuel Lemos10 May
          • Re: AUTO_INCREMENT bug after inserting negative valueMichael Widenius10 May
            • Re: AUTO_INCREMENT bug after inserting negative valueManuel Lemos5 Jun